View Full Version : Problem on LTQ - Accessing Liberty Park

09-11-2013, 11:18 PM
Is anyone else having problems accessing the Liberty Park map? I can get into all the other maps as far as I can see but I'm stuck on the level. The game just sits there with the "travelling to Liberty Park" splash screen displayed, and that's as far as I can progress.

I've rebooted the game, tried to get to the map via the LTQ goals and the Maps list, but no joy. I've submitted a ticket but the LTQ will be over before it gets resolved, I suspect, so I wondered of anyone had a solution? :(

09-12-2013, 05:46 AM
My game crashes almost every time I try to load that map. I sent in a ticket a couple days ago, but I haven't received a response yet. The only thing that worked for me I'm thinking was a fluke - instead of loading Liberty Park through the map section, I accessed the map by clicking the ltq mission in the goals list and clicked "visit" button beside the FIRST goal listed to be completed. I tried clicking on any other goal in that list and the game would crash. I tried accessing Liberty Park through the main Maps button, and the game would crash.

I hope it works for you, lol but I have a feeling it's just a fluke.

09-12-2013, 10:47 AM
Thanks, Tigris, for being so helpful. :))) The first goal made me crash as well, unfortunately, but I'm reassured that it wasn't simply data corruption at my end. I've reinstalled and got past the level now. I got a quicker response her than from Gree. Still waiting.... Lol

09-12-2013, 12:45 PM
Lol while I'm not surprised, I'm glad you were able to get past the map :)

Good luck this weekend!

09-12-2013, 01:54 PM
And you :)