PDA

View Full Version : Package File is Invalid



Crowe77
02-23-2014, 07:52 AM
Its been a day now where I'm locked out of the game due to the new update. Missing the boss raid and daily log on. Gree, any update on this? I can't send a ticket in because I can't open the app, just keep getting a forced close.

Commander X2
02-23-2014, 08:51 AM
You can email them en-support@gree.net

Oceanz
02-23-2014, 09:08 AM
Might not help, but try freeing up some space on your device

Commander X2
02-23-2014, 11:28 AM
I has same issue and I emailed and it was fixed

B Johnson
03-09-2014, 07:32 AM
This same issue came up over a week ago for my son. He has emailed Gree twice, last reply from Gree said it was fixed. Go figure, it wasn't fixed. He still can't download the game without getting this error...how can a company just blindly tell you something is fixed when its not? Wish I got paid to lie to people like that....how frustrating!

pb23
03-09-2014, 03:22 PM
This happened to one of my guys... he has been locked out since the Friday of Finland WD.

Gree put it back on Google Play (android) and said it was not their issue. Downloading an old version helped him get up and running. Still no solution for the current version.

Yee
03-10-2014, 12:35 AM
Good luck to you! Mine was locked out more than a month, with them saying they resolved it every time I emailed to them

Biker
03-10-2014, 06:45 AM
I have a faction mate with the same problem, updated. MW and now can't get in, it has been over a week now, she sent an email in and the ticket was closed and told her they are aware and will fix it and advise her in game. So how exactly can you advise someone in game if you can't open the game lmao. I even posted here and had a mod say it was google plays issue. Called google play and they advised her device is compatable so not the issue from their end.
Just another way to drive your customers away from the game, she missed the entire crate event and now the boss event.

Tardavic
03-10-2014, 05:06 PM
Hey guys, we do understand that this can be frustrating and are here to help you in any way we can.

First of all, for those of you affected could you please provide what your device type is and then we can go from there?

Winalot
03-11-2014, 01:38 AM
Hi Tardavic ..
Big thanks for your help to try push this BIG problem forward
( Package File is Invalid ) when downloadingfrom app store ..

here is my phone model : Device: HTC Desire HD A9191

anything more i can do ?..
I already filled the issue report 12 days ago but not received a single respond ?
been playing for more than a year .. and as officer i now cant help my faction any longer and people
dont understand why i dont play anymore

JT77
03-11-2014, 01:54 AM
I also had this problem.

HTC Desire HD

Package file is invalid and no LTBs for months. Got the same response from support that the problem has been fixed. I downloaded an old apk and installed and am able to carry on with the game.

Version is 3.8.1.1 data mw_20140310_9

Winalot
03-11-2014, 04:02 AM
Hi JT77 , can you point me to the location where you got the old apk install file from that works on your
Desire HD
Thanks

5t0rm
03-11-2014, 07:19 AM
I tried to do the latest update also. Had to uninstall and won't let me reinstall. Tried an older version and ot constantly forced close would'nt even let me in game. Called googlle play and was informend that game update was compatible with my device. That it is a Gree problem. Emailed and recieved standard we are aware of the problem etc. Please help!!!

Dixie_Boy
03-11-2014, 07:27 AM
Wish I got paid to lie to people like that....how frustrating!

Be a meteorologist then

Crowe77
03-11-2014, 02:02 PM
HTC Droid Incredible 2

Tardavic
03-11-2014, 03:16 PM
Hey guys, just spoke with our developers and I have provided a link to what version of HTC Desire HD:

http://forum.xda-developers.com/htc-desire-hd

It looks like by default it's 2.2, as we don't support that since 3.8.x

I look forward to your feedback!!

Winalot
03-12-2014, 04:06 AM
Hi again Tardavic
BIG thanks again for your effort in helping out to get our HTC desire HD able to play this game again in your latest release . the Android version i have installed is 2.3.5

For me today was a sunny day :cool:
.. as you know from my previous post i filled my issue report 10 days ago
then yesteerday i got the first reply back from gree support that they would try to help me restore my account .. i searched the net and found a older modern war apk installed it and made a dummy base level 1
then i gave gree support my old player id and some more personal data .. and they could swap my old account in on the dummy base .. so NOW i can support my faction and friends again .. wohoo

But Tardavic one quistion remain for me to be understood ?
Do you say that my phone HTC Desire HD A9191 running Android version 2.3.5 is not supported in your future releases form developers ?
So same problem will happen again . or did you say your will make sure the developers also support that phone model ??

Hope you answer - thanks
Enjoy your day

JT77
03-12-2014, 05:02 AM
Glad to see you got sorted Winalot. Just in case anyone else comes across this thread, I got the old apk from 1mobile. When I installed it on my phone everything was restored as it had been, still with the le buildings invisible, but at least I can play.

Tardavic before I did my foolish reset, I had been running version 3.9.2 on the Desire HD with Android 2.3.5

Veccster
03-12-2014, 08:17 AM
I had the app on my HTC Incredible. I reset the phone and it deleted the app. Unfortunately, I am now unable to DL from the app store and get the dreaded Package File Invalid message. I'll try downloading the version Tardavic posted a link to. Hopefully that enables me to play once again.

Tardavic
03-12-2014, 04:06 PM
Hey guys, I have received some more information from the developers and with the devices "HTC Thunderbolt and HTC Desire", the cache memory is too low and our APK size is too big.

This is a known issue on some older devices, however there's also an issue with downloading huge apk from the market, but these issues are out of our hands.

I will try and provide any other updates I can for you all and appreciate the understanding and positivism!!

Berio
03-12-2014, 05:21 PM
Guys, I am using a old model of Samsung phone which also has the package file invalid.
Phone model Samsung S Advance GT-I9070
I uninstall the game and now is unable to download the game again

JT77
03-13-2014, 04:14 AM
Hi Berio, I got the apk for 3.8.1.1 from 1mobile.com. If you do a search for modern war the current one will be at the top, just scroll down. I installed it and everything from my base, gold etc was still there. Hope you get sorted

5t0rm
03-13-2014, 09:15 AM
I tried to do the latest update also. Had to uninstall and won't let me reinstall. Tried an older version and ot constantly forced close would'nt even let me in game. Called googlle play and was informend that game update was compatible with my device. That it is a Gree problem. Emailed and recieved standard we are aware of the problem etc. Please help!!!

Samsung galaxy S blaze SGH-T769

pb23
03-13-2014, 10:35 AM
Hi Berio, I got the apk for 3.8.1.1 from 1mobile.com. If you do a search for modern war the current one will be at the top, just scroll down. I installed it and everything from my base, gold etc was still there. Hope you get sorted

It is laughable that we, as the community, have to put our heads together to find a way to circumvent a broken game. Yet support stays quiet on the matter or shirks the blame to a 3rd party. Typical.

Keep up the good work helping each other out guys. There are MANY people with this issue, and I'm sure they'll stumble onto this thread and be thankful for any solutions (or workarounds really) that are provided by the community.

Tardavic
03-13-2014, 02:53 PM
Much appreciated everyone for putting together suggestions and work-a-rounds, keep up the good work!!

nowerman
03-16-2014, 08:19 AM
I've been locked out over a month now due to the package file invalid problem. Versions released yesterday did not fix the issue and gree has not responded. Can someone help me get my game going again?

Phone is a galaxy exhibit 4g thanks

Berio
03-17-2014, 08:34 AM
Hi Berio, I got the apk for 3.8.1.1 from 1mobile.com. If you do a search for modern war the current one will be at the top, just scroll down. I installed it and everything from my base, gold etc was still there. Hope you get sorted

Do the game update by it self? I am not getting the box event.

Dixie_Boy
03-17-2014, 10:51 AM
Much appreciated everyone for putting together suggestions and work-a-rounds, keep up the good work!!

Sub-text : thanks for doing what we can't/won't do.

zagyexpress
03-19-2014, 05:12 AM
i have the same problem, my device is Samsung Galaxy S Mini 2. I tried downloading from alternate market but it also doesnt help, does anyone have the link to some prior version I can use for android also?

zagyexpress
03-19-2014, 05:31 AM
i have the same problem, my device is Samsung Galaxy S Mini 2. I tried downloading from alternate market but it also doesnt help, does anyone have the link to some prior version I can use for android also?


now even old version 3.8.1.1 wont install properly

JT77
03-19-2014, 11:50 AM
Mine is working ok and showing all the events since I uninstalled 3.9.2 to update to 3.whatever it is now. Only thing is I sometimes have to go through 3-5 crashes on startup before it runs, but it's better than nowt!

Riddle
03-24-2014, 12:37 AM
I would like to know what happened to customer service! using htc incredible new update on 2-27 was invalid. I'm inconvenienced and buy a tablet to have the game transferred. A month later still don't have it back. Ten emails later sorry for delayed responses to have Gree tell me its not my game and will not transfer!?! REALLY

Tardavic
03-24-2014, 03:31 PM
Hey guys, have another quick update from our developers for those having the invalid package issue.

We have fixed the client, but we can't fix individual issues due to hardware, software, firmware, or Google issues.

Some people have had to re-add their Google account or reset their GooglePlay store app to fix this. You can also refer to the following link to see how to fix this:

http://www.reddit.com/r/Android/comments/1jygqm/package_file_is_invalid_how_do_i_fix_it/

Riddle
03-25-2014, 10:25 PM
That doesn't help me. Broke the phone after game didn't work, so can someone look into my transfer problems?? Ticket number is 1433399. Thanks

Riddle
03-27-2014, 09:47 AM
I would like not to have to make new thread about asking. Getting aggravated now. I was on a top 250 faction and losing rewards!

Commander X2
03-27-2014, 12:46 PM
Mine was working okay then had to update and now invalid package file

Philly982
03-27-2014, 04:40 PM
I know of a lot of players that are having issues with the "Package File is Invalid" on this new Android update. Does this mean that they will not be able to participate in Frontal Assault.

Ulrich von Bek
03-27-2014, 05:34 PM
Having the same issue. I have tried all the suggested work arounds and even had to reset my phone to factory default to remove my Google account.

Tardavic
03-27-2014, 06:13 PM
Hey guys, we understand that this is still an issue and have been looking into this.

For the time being, we recommend that you clear your Google play app data. Re-launch your Google play app then login again and reinstall the MW Android app.

Once we have more details we will let you know and we really do apologize for the inconvenience.

Philly982
03-27-2014, 06:43 PM
Thanks Tardavic. Unfortunately that did not work for me or my friends. Does this mean that a portion of your Android users will not be able to participate in the Frontal Assault event?

Christopher Chua
03-27-2014, 09:27 PM
This invalid package issue is difficult to fix since some players are able to update without any issues. We have also tried to reproduce the issues on the reported devices and we are able to install the the APK from the Google Play Store.

The most common fix is to go to the Google Play Store App in your Settings and clear the cache, then switch off your wifi and use your network. Re-open the Google Play Store and install MW Android again.

Also try this if it doesn't work.
http://advicesacademy.com/how-to/fix-package-file-is-invalid-error-android/

Lord Green
03-27-2014, 10:50 PM
What about getting a more modern mobile? That seems like the easier route to take. Don't know how pricey that'll be, but its a sure fix

Winalot
03-28-2014, 03:28 AM
What about getting a more modern mobile? That seems like the easier route to take. Don't know how pricey that'll be, but its a sure fix

If the game is offered to any Mobile in Android App store Then that indicate it is compatible to that device.
And THEN it should work smoothly and have a SIZE of installation packet that fit !
Rest is just cheating the customer base ..

I understand that a game can evolve over time and get bigger and change direction .. but
THEN is should not any longer be found offered in my App store .

GREE please make sure to inform Google Play about the phone you don't support any longer
this is the only way you can ensure happy customers !!!

Br sir winalot

Unhappy owner of HTC Desire HD -
which apparently again is not able to install you latest version v.4.0.0
im having version 3.9.3 running but cant upgrade to 4.0 - ( Invalid File )

Gen CheeBye
03-28-2014, 04:20 AM
Unhappy owner of HTC Desire HD -
which apparently again is not able to install you latest version v.4.0.0
im having version 3.9.3 running but cant upgrade to 4.0 - ( Invalid File )


I'm very sorry to inform you...I own the same device and have thrown it away because the android version is too old and not supported by MW.

Gree will not make that official but you will need android version 4 and above if you still plan to continue playing MW.

Try transferring the game to a newer device that supports android version 4...you will see what I mean.

Good luck.

GBA
03-28-2014, 06:11 AM
I have the same problem (invalid package file) when I attempted to update MW. Now I can't get in. Most likely this issue only impacts Android players and not the majority iPhone players so GREE is going to take their time resolving this issue. The last time this happened to me, I wasn't able to login for a week. I'm using an Android (v2.3.4) LG-VS700 device.

slgreenwell
03-28-2014, 06:51 AM
I'm having this issue on my Sony Ericsson Experia Play
Model R800x. Running android version 2.3.3. I've tried all the fixes even did a factory reset on phone. Nothing has helped. I can't justify getting a new phone just because modern war app doesn't work.

Gen CheeBye
03-28-2014, 07:30 AM
I'm having this issue on my Sony Ericsson Experia Play
Model R800x Running android version 2.3.3. I've tried all the fixes even did a factory reset on phone. Nothing has helped. I can't justify getting a new phone just because modern war app doesn't work.



That's the reality. Android devices running on version 2 are the most affected.

barmaleikin
03-28-2014, 02:20 PM
Hi,

Seems I affected by this too. Firmware 2.3.3. Gree should announce this officially if this is not a glitch.

Christopher Chua
03-28-2014, 02:38 PM
What was the previous builds that worked for you guys having the invalid package file issue?

Dilligaf13
03-28-2014, 04:28 PM
Last time this happened I deleted and reinstalled and was locked out for over a month and then was screwed out of everything my faction earned in the faction events because I my account was considered inactive. I can't do the new event same as all of you and have found out that gree no longer supports older versions of android so for me to continue to play I have to buy a new phone. I guess it's looking like they may be losing a lot of players due to this according to what I've been reading on other post. Looks like I'm taking another vacation for the next few days to see if I'm able to do any of the other events or not. Good luck all.

zathoinay22
03-28-2014, 05:42 PM
plugin kiếm thế 4.0.3
________________

map kiếm thế ai
(http://kiemthelauvn.com/tin-tuc.html) , kiem the free 2014
(http://kiemthelauvn.com/) , Khach san Mui ne
(http://www.vinaday.com/daytrips/Cambodia/siem-riep
) , Khach san Mui ne
(http://www.vinaday.com) , Cu Chi tunnels (http://www.vinaday.com/daytrips/viet-nam/saigon,ho-chi-minh-south-vietnam/cu-chi-tunnels-half-day) , left
(http://khoavang.vn/tin-tuc/lenovo-gioi-thieu-laptop-gia-re-cho-doanh-nhan_124.html

)

jackattack.mw
03-28-2014, 07:31 PM
I have a droid3 with v2.3.4. Probably too old but let me know if there's a work around.

On a side note I have two other members of my faction both on iOS. After they declare war they cannot see any results. They also cannot deploy any units. Nothing shows up and the queue remains empty. It was like this for the entire war. Rebooting devices doesn't seem to fix the problem.

Just wanted you to know.

Jackattack

Adam96
03-28-2014, 07:44 PM
i had to uninstall the game cuz of all the data downloads now when i go to reinstall it i get an error package file is invalid i sat on the phone with google for an hour and a half doin all the trouble shooting and even did a factory reset on my phone nothing iv had this problem be for and my device is an lGl38c if nothing else can u send me a copy of the apk???

Time Killer
03-28-2014, 08:02 PM
So anyone with an older android should just forget playing Modern War?

Doesn't seem like you have posted anything along the lines as your working on a solution to the issues.

Christopher Chua
03-28-2014, 09:01 PM
Hey Guys,

There is a new build being rolled out to production right now with a potential fix to "Invalid Package File".

v.4.0.1
{BUG FIX} Full Assault crash and chat fixes
{BUG FIX} Fix most of "Package File Invalid" issues. NOTE: Re-install if you had this issue.

Please let us know if you guys are still having issues.

We will monitor the crashes and increase the release to 100% if everything looks good.

Fuqitall
03-28-2014, 09:18 PM
Hey Guys,

There is a new build being rolled out to production right now with a potential fix to "Invalid Package File".

v.4.0.1
{BUG FIX} Full Assault crash and chat fixes
{BUG FIX} Fix most of "Package File Invalid" issues. NOTE: Re-install if you had this issue.

Please let us know if you guys are still having issues.

We will monitor the crashes and increase the release to 100% if everything looks good.

Any idea when this fix will be launched? Just tried again now and still getting the invalid package file message. I'll keep checking hopeful to see the new update being released.

Winalot
03-29-2014, 03:48 AM
the new version V.4.0.1 is now working on my HTC DESIRE HD

:cool:

JT77
03-29-2014, 04:23 AM
Kinda mixed emotions here. Its now working on my Desire HD which is great. How was it fixed in less than 12hrs when we have been reporting the issue for months!?

Herr Otto
03-29-2014, 04:52 AM
This happened to one of my guys... he has been locked out since the Friday of Finland WD.

Gree put it back on Google Play (android) and said it was not their issue. Downloading an old version helped him get up and running. Still no solution for the current version.

Same with me....had to download an older version just to get back into the game. Who knows how that will screw me down the road.

Kaarduk Useb
03-29-2014, 05:52 AM
Ok this fix worked perfectly but now when I try to open MW it gives me black screen and i need to do Force Close:-(
Using Samsung Xcover s5690

Zane12
03-29-2014, 02:52 PM
The fix worked for me to re-install the game but now i have to start over. Why can i not use my original account??

Berio
03-30-2014, 09:45 AM
Ok this fix worked perfectly but now when I try to open MW it gives me black screen and i need to do Force Close:-(
Using Samsung Xcover s5690

Did you uninstall and install again?

slgreenwell
03-30-2014, 10:18 AM
Downloaded version 4.0.1 and it loaded and opened just fine. Only problem is my profile is gone. I guess I need to send in a ticket to get my profile back

miaomiao
03-30-2014, 09:18 PM
I tried to update my mw but is says device not supported. Uninstall in and now cant even find the mw apps in my apps store. Im using S2, need help. Thx

Jack07
04-02-2014, 05:27 AM
Members in faction need to upgrade software, wondering if anyone was able to update their devices so far ?